Subscribe:

2010/11/23

phpmyadminについて小ネタ

phpmyadminのバージョンとphpとmysqlの必須バージョン
[table id=1 /]phpMyAdminのタイムアウト時間延長方法(Ver.3.3.8)
\var\www\phpmyadmin\libraries\config.default.php[php num="588" highlight_lines="588" toolbar="false" font_size="110%"]
$cfg['LoginCookieValidity'] = 1440;[/php]
↑タイムアウト時間を設定(86400秒にした)
修正後からphpmyadminにエラーが表示される。
「Your PHP parameter session.gc_maxlifetime is lower that cookie validity configured in phpMyAdmin, because of this, your login will expire sooner than configured in phpMyAdmin.」
無視していれば特に問題ないが気になるのなら修正
\var\www\phpmyadmin\main.php↓[php num="293" highlight_lines="295" toolbar="false" font_size="110%"]
$gc_time = (int)@ini_get('session.gc_maxlifetime');
if ($gc_time < $GLOBALS['cfg']['LoginCookieValidity'] ) {
// trigger_error(PMA_Message::decodeBB($strSessionGCWarning), E_USER_WARNING);
}[/php]295行をコメントアウト

all-languagesをインストールすると日本語以外もインストールされるので削除
# du -hs /var/www/phpmyadmin/lang
7.5M /var/www/phpmyadmin/lang
# cp /var/www/phpmyadmin/lang/japanese-utf-8.inc.php /var/www/phpmyadmin/japanese-utf-8.inc.php
# find /var/www/phpmyadmin/lang -name "*.inc.php" -exec rm {} \;
# mv /var/www/phpmyadmin/japanese-utf-8.inc.php /var/www/phpmyadmin/lang/japanese-utf-8.inc.php
# du -hs /var/www/phpmyadmin/lang
164K /var/www/phpmyadmin/lang
7.5M→164Kになってスッキリ!

0 件のコメント: